Testo nero su sfondo nero: problemino...

Se stai imparando a costruirti il tuo template qui trovi consigli e risposte ai tuoi dubbi sull'HTML

Moderatori: Moderatori iobloggo, Moderatori HTML & Grafica

Testo nero su sfondo nero: problemino...

Messaggioda fuochifatui » 25 settembre 2004, 14:10

Ciao a tutti, vorrei modificare il colore di sfondo del template, ma ho alcuni problemi. Il template di base che uso è quello del geco, anche se è stato modificato. Ho provato a cambiare il colore del background da bianco in nero (inserendo la stringa background-color: #000000 nella giusta posizione, come ho letto qui sul forum). A questo punto, naturalmente, tutto ciò che è testo, è “scomparso” (poiché testo nero su sfondo nero). Così, laddove, nel template, il font era nero, ho convertito il codice del colore da #000000 (nero) a #FFFFFF (bianco). Sono stata attenta a non lasciarmi sfuggire nessun codice. A questo punto sono riapparsi i link ai miei blog preferiti e agli autori di layout e script. Tutto il resto del testo (presentazione, titoli delle sezioni quali “archivio”, “contatti”, “links”, il counter, e via dicendo) è ancora nero, e dunque non visibile. Anche la barra di iobloggo (in alto) è stranamente oscurata.
Come potete capire, non sono espertissima di Html –eufemismo :)
Perciò se qualcuno può darmi una mano e suggerirmi come e dove intervenire nel template... Muchas gracias
:)
fuochifatui
inesperto
inesperto
 
Messaggi: 14
Iscritto il: 6 luglio 2004, 12:55

Re: Testo nero su sfondo nero: problemino...

Messaggioda lozioric » 25 settembre 2004, 14:33

fuochifatui ha scritto:Ho provato a cambiare il colore del background da bianco in nero (inserendo la stringa background-color: #000000 nella giusta posizione, come ho letto qui sul forum). A questo punto, naturalmente, tutto ciò che è testo, è “scomparso”


Ecco, benissimo fin qui. Però oltre a

background-color: #000000;

meglio mettere anche

color: #FFFFFF;

altrimenti il browser usa il colore di default, vale a dire, indovina un po'... esatto, nero. :D

Dove hai messo #FFFFFF al posto di #000000 hai fatto bene, ma probabilmente hai modificato il colore solo di alcune parti della pagina. Se invece aggiungi il settaggio color dove hai messo anche background-color, dovunque lo sfondo sia diventato nero il testo diventerà bianco.
Avatar utente
lozioric
dipendente
dipendente
 
Messaggi: 935
Iscritto il: 2 settembre 2004, 9:19

Messaggioda fuochifatui » 25 settembre 2004, 15:23

Dunque, prima di tutto grazie per la risposta :)
Però temo di aver provato anche quello...
Il template della pagina, al momento (sfondo bianco/testo nero) inizia così:

title>--titolo--</title>
<style>
td, body
{font-family:tahoma;font-size:11px;}
{width: 100%;}
a
{color:#000000}
a:hover
{color:#96B4DE}

Inserendo la stringa che indica quale colore assegnare al background, avevo naturalmente pensato subito di modificare la riga {color:#000000}
Immaginavo che quello fosse il colore di default del testo... quindi cambiato quello, mi illudevo che magicamente tutto il testo sarebbe riapparso in bianco. Invece, ahimé, non è andata così :?
Solo tutto il testo che costituicse un link diventa bianco: e quindi, i link ai blog che leggo più spesso, i link agli autori di layout e script, i link sotto i post che rimandano alle categorie e all'ora del post stesso.
L'unico link che non appare è quello dei commenti, perché chiaramente lì bisognerà intervenire sul template dei commenti (ma lì ho già provato e non ci sono problemi).
Tutto ciò che è "puro testo" resta nero... e non c'è verso di converitirlo in bianco, anche agendo su tutti i "codici neri" del template.
Temo di dover inserire io, da qualche parte, i "codici bianchi"... il problema è che non so dove... ho fatto alcuni tentativi, ma nada de nada.
fuochifatui
inesperto
inesperto
 
Messaggi: 14
Iscritto il: 6 luglio 2004, 12:55

Messaggioda fuochifatui » 25 settembre 2004, 15:27

Ah, che pisquana... ma certo, quel codice {color:#000000} all'inizio del template mi sa che è proprio quello dei link... quando non sono stati ancora visitati. Comunque, ho provato a fare anche esattamente come mi suggerisci tu. Niente, tutto nero lo stesso :cry:
fuochifatui
inesperto
inesperto
 
Messaggi: 14
Iscritto il: 6 luglio 2004, 12:55

Messaggioda lozioric » 25 settembre 2004, 15:51

La modifica da fare è questa:

fuochifatui ha scritto:<title>--titolo--</title>
<style>
td, body {
font-family:tahoma;
font-size:11px;
color: #FFFFFF;
background-color: #000000;
}
{width: 100%;}
a
{color:#000000}
a:hover
{color:#96B4DE}


Le parti in grassetto indicano le aggiunte.

La riga in rosso puoi toglierla, non ha nessun effetto in quanto non è associata a niente.

Ti consiglio inoltre di togliere anche la parte in verde o, se questo creasse dei problemi in visualizzazione, di raddoppiare le istruzioni (cioè scrivere body{...} e poi td{...} con le stesse istruzioni dentro); lo stesso per ogni stile applicato a più elementi separati da virgole. Questo perché altrimenti alcuni browser (Mozilla, Firefox, ecc.) non visualizzeranno correttamente la pagina.
Avatar utente
lozioric
dipendente
dipendente
 
Messaggi: 935
Iscritto il: 2 settembre 2004, 9:19

Messaggioda Lucretia » 25 settembre 2004, 16:12

ehi Ric... colgo la palla al balzo e ti chiedo, quando hai tempo e voglia, un paio di spiegazioni. Senza fretta perché tanto io ora ho un sacco di cose da fare invece di mettermi a smanettare con il template, ma cmq è una cosa che mi interessa e che penso possa interessare anche ad altri.

Insomma. Perchè non dai qualche consiglio utile (indirizzato a chi ha già qualche nozione di html) per creare un template che risulti decente con tutti i browser (come hai appena fatto qua sopra, insomma)? Dicendo magari che cosa funziona e cosa no (mi vengono in mente effetti come l'opacità, come le piccole immagini sul mio blog) e cose del genere, e come evitare errori grossolani che compromettono una visualizzazione corretta...

penso che sarebbe molto utile, ecco.

:wink:
Immagine. pretend to love my imperfection at least for a minute .

// . reflection .
// . readthefuckingmanual . guida . faq . search
Avatar utente
Lucretia
Admin
Admin
 
Messaggi: 5121
Iscritto il: 15 marzo 2004, 16:45
Località: home is where the heart is

Messaggioda fuochifatui » 25 settembre 2004, 16:29

Grazie mille :) Avevo provato a inserire il codice-colore del testo anche nella stringa del font, ma non avevo inserito il codice-colore del background, che stava più in alto. Ora è tutto a posto. La riga in rosso l'ho inserita per errore tempo fa, ma mi ero dimeticata di cancellarla :?
Il fatto è che procedendo empiricamente, se ne fanno di casotti...
Ciao e grazie ancora dell'aiuto.
fuochifatui
inesperto
inesperto
 
Messaggi: 14
Iscritto il: 6 luglio 2004, 12:55

Messaggioda fuochifatui » 25 settembre 2004, 17:14

Aehm... :? Non strozzatemi... ma è rimasto solo un problemino... la barra di iobloggo continua a non vedersi. Se qualcuno ha avuto lo sesso problema e sa dirmi come fare, lo ringrazio molto.
fuochifatui
inesperto
inesperto
 
Messaggi: 14
Iscritto il: 6 luglio 2004, 12:55

Messaggioda fuochifatui » 25 settembre 2004, 17:20

Ok, ho visto che c'è una sezione dedicata proprio alla barra... cercherò lì la soluzione. Scusate per la marea di messaggi e grazie ancora.
fuochifatui
inesperto
inesperto
 
Messaggi: 14
Iscritto il: 6 luglio 2004, 12:55

Messaggioda lozioric » 26 settembre 2004, 2:02

Lucretia ha scritto:ehi Ric... colgo la palla al balzo e ti chiedo, quando hai tempo e voglia, un paio di spiegazioni. [...]


Da un paio di settimane ormai seguo regolarmente il forum, quindi se posti in questa sezione è probabile che io voglia metterci la pezza. :P

Continuo la risposta nella sezione Off Topic, per ovvi motivi. :wink:
Avatar utente
lozioric
dipendente
dipendente
 
Messaggi: 935
Iscritto il: 2 settembre 2004, 9:19

Messaggioda lozioric » 26 settembre 2004, 2:04

fuochifatui ha scritto:Ora è tutto a posto. [...] Ciao e grazie ancora dell'aiuto.


:)
Avatar utente
lozioric
dipendente
dipendente
 
Messaggi: 935
Iscritto il: 2 settembre 2004, 9:19

Messaggioda lozioric » 26 settembre 2004, 7:55

lozioric ha scritto:
Lucretia ha scritto:ehi Ric... colgo la palla al balzo e ti chiedo, quando hai tempo e voglia, un paio di spiegazioni. [...]


Da un paio di settimane ormai seguo regolarmente il forum, quindi se posti i tuoi dubbi in questa sezione è probabile che io voglia metterci la pezza. :P

In effetti però servirebbe qualcosa che colmi il vuoto cosmico che inizia dove finisce la guida di iobloggo... anche perché cercare info sul forum, magari vecchie di mesi, non è il massimo della praticità. Esiste html.iobloggo.com ma è fermo da febbraio.
Se facessi qualcosa tipo guida.avanzata.per.smacchinare.sui.temp ... bloggo.com, sarebbe una cosa utile?
Avatar utente
lozioric
dipendente
dipendente
 
Messaggi: 935
Iscritto il: 2 settembre 2004, 9:19

Messaggioda Lucretia » 26 settembre 2004, 11:42

se ne hai voglia, secondo me è una cosa molto utile. i dubbi sull'html per noi autodidatti non finiscono mai! :)
Immagine. pretend to love my imperfection at least for a minute .

// . reflection .
// . readthefuckingmanual . guida . faq . search
Avatar utente
Lucretia
Admin
Admin
 
Messaggi: 5121
Iscritto il: 15 marzo 2004, 16:45
Località: home is where the heart is

Messaggioda Lucretia » 26 settembre 2004, 19:51

ecco, per esempio, un'altra cosa che volevo chiedere da un po' di tempo.

come si fa a permettere la scelta di una skin al visitatore? come il blog di Anija, per capirci...

:wink:
Immagine. pretend to love my imperfection at least for a minute .

// . reflection .
// . readthefuckingmanual . guida . faq . search
Avatar utente
Lucretia
Admin
Admin
 
Messaggi: 5121
Iscritto il: 15 marzo 2004, 16:45
Località: home is where the heart is

Messaggioda lozioric » 26 settembre 2004, 22:48

Lucretia ha scritto:ecco, per esempio, un'altra cosa che volevo chiedere da un po' di tempo.

come si fa a permettere la scelta di una skin al visitatore? come il blog di Anija, per capirci...

:wink:


Apro un altro topic, che qui l'OT è in agguato... :wink:
Avatar utente
lozioric
dipendente
dipendente
 
Messaggi: 935
Iscritto il: 2 settembre 2004, 9:19


Torna a HTML, CSS e Javascript

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron