Pagina 1 di 2

Fluttuare l'immagine a destra

MessaggioInviato: 9 agosto 2005, 21:01
da Alexiel
allora, il punto è questo:
ho inserito il nuovo tag personalizzabile di iobloggo, per le immagini. però invece dell'immagine centrata in alto vorrei la stessa immagine, sempre in alto ma a destra. ho provato a farlo, ma poi il testo rimane sotto, e non riesco a far sì che l'inizio del post, invece, appaia sulla sinistra dell'immagine stessa. inoltre non voglio alcun bordo all'immagine, e vorrei che, nel caso io non voglia inserirla, il post mi resti centrato come quelli vecchi. forse non sono stata molto chiara, nel caso rispiegherò. per capirmi meglio visitate il mio blog ^___^

ringrazio in anticipo il genio dell'html che mi aiuterà!!! :D

MessaggioInviato: 9 agosto 2005, 21:52
da anija
Codice: Seleziona tutto
<img src="..." alt="..." title="..." style="float:right">
è il codice per farla "fluttuare" a destra :)

MessaggioInviato: 9 agosto 2005, 22:03
da Alexiel
e vicino a alt che ci va??

MessaggioInviato: 9 agosto 2005, 22:08
da anija
Alexiel ha scritto:e vicino a alt che ci va??


mm allora
alt = alternative text.
è il testo che compare nel caso l'immagine non ci sia, è buona norma metterlo :) con internet explorer l'alt compare anche passando il mouse sopra.

title = serve a far comparire anche in firefox la scritta al passaggio del mouse

quindi esempio:
Codice: Seleziona tutto
<img src=".../logo.gif" alt="logo azienda" title="logo azienda">

MessaggioInviato: 9 agosto 2005, 23:43
da Alexiel
anjia non ci sto capendo più nulla! :o

allora... la parte riferita al post è questa...
Codice: Seleziona tutto
<TABLE WIDTH=367 BORDER=0 CELLPADDING=0  CELLSPACING=0 height="0">
<td class="main" align="center" width="658" height="40" colspan="3">

<br>

--campo_immagine--
--post--


<b><br>--nome-- イラリア</b>
<p></td>
</TABLE>


e il campo alternativo invece è:
Codice: Seleziona tutto
<img src="" border="0" height="0" width="100" style="float:right">

però continua a non comparirmi a destra!

help! :x


ps: ...e se nn volessi nulla al posto dell'immagine?

MessaggioInviato: 10 agosto 2005, 9:59
da NatroN
Alexiel ha scritto:
help! :x


ps: ...e se nn volessi nulla al posto dell'immagine?


Su questo punto ho dato una soluzione a Britkillah che fa anche al caso tuo, io l'ho provato e funziona, la trovi qui

MessaggioInviato: 10 agosto 2005, 14:24
da Alexiel
:(
mi dispiace, ma stavolta proprio non so più che fare... l'immagine è sempre al centro, e non si smuove in alcun modo...
speravo che dando il codice html della tabella del post mi trovassi un errore... :(
di solito trovo sempre una soluzione, ma stavolta... :ko:

MessaggioInviato: 10 agosto 2005, 14:33
da anija
Il post "MSN anche a ..." in cui hai messo l'immagine
Immagine
aveva, come valore del campo:
Codice: Seleziona tutto
<img src="http://alexiel85.altervista.org/_altervista_ht/kawai.gif" border="0">

senza float!
Ti ho aggiunto io il float ora, e funziona :)

MessaggioInviato: 10 agosto 2005, 14:41
da Alexiel
wow è vero!
però quando non metto lìimmagine il primo rigo si allenea a sinistra... ho letto sul forum quello che hai scritto per evitare il problema, ma non c'ho capito nulla! :(

MessaggioInviato: 10 agosto 2005, 15:46
da Alexiel
forse la soluzione è cancellare il campo quando non devo mettere l'immagine!!!
tanto non ci vuole niente!

MessaggioInviato: 10 agosto 2005, 16:00
da anija
Alexiel ha scritto:forse la soluzione è cancellare il campo quando non devo mettere l'immagine!!!
tanto non ci vuole niente!

sì sì ^^ scusa, non avevo capito, pensavo già lo cancellassi :)

MessaggioInviato: 10 agosto 2005, 16:09
da Alexiel
^____^ eheheheh
good finalmente quindi mi sono raccapezzata! :D

MessaggioInviato: 21 settembre 2005, 18:42
da *Alisea*
Non sapendo se ho postato al posto giusto inserisco la mia domanda anche qua...

Sto cercando di inserire anch'io il campo aggiuntivo per le immagini accanto ad ogni post, ho compilato il campo Titolo e Tag mentre per il Valore predefinito ho qualche dubbio... io ho inserito questo codice:

Codice: Seleziona tutto
<img src="" border="0" alt="" style="float:right">


perchè vorrei che la mia immaginina fosse sulla dx in alto... ma in realtà mi compare a dx ma in fondo al post... come faccio a sistemarla in alto? Sbaglio qualcosa? Grazie!

MessaggioInviato: 21 settembre 2005, 19:18
da Morgaine
dipende dove hai messo nel template il tag del campo.

Se metti

--campo_immagine--
--post--

e metti il float right l'immagine sarà alla destra della scritta del post.

se invece metti

--post--
--campo_immafine--

lì'immagine apparirà sotto il post, probabilmente alla destra delle scritte di commenti e trackback se le hai in fondo al post.

se vuoi che appaia a destra ma sopra il testo devi mettere

align="right" invece dello style con il float.

MessaggioInviato: 21 settembre 2005, 21:12
da *Alisea*
Grazie Morgaine sei stata gentilissima, ho inserito il campo dell'immagine prima del post però non mi torna ancora l'allineamento a dx come lo vorrei io... ti spiego... a me risulta così:

Immagine

mentre lo vorrei - come l'ho impostata qui manualmente - esattamente così proprio al pari del testo:

Immagine

Sai aiutarmi per farla apparire così? Cosa devo aggiungere?
Grazie mille in anticipo, ciao!
:ciao: