Post senza tag che sballano tutto!

Se stai imparando a costruirti il tuo template qui trovi consigli e risposte ai tuoi dubbi sull'HTML

Moderatori: Moderatori iobloggo, Moderatori HTML & Grafica

Post senza tag che sballano tutto!

Messaggioda Alexiel » 23 novembre 2011, 1:44

Nel caso qualcuno se ne intendesse, ho scoperto un errore che mi sballa il template: succede solo quando nella pagina ci sono post ai quali non sono associati tag. Ad esempio, se andate a vedere Luglio 2008, nella prima pagina, l'ultimo post è quello che sballa tutto. Non avendo i tag non si legge neppure il post. Spero di riuscire a risolvere il problema da sola (magari domani che ora sono stanca) ma se intanto passa qualcunoa darmi una mano, non mi dà fastidio :D
Probabilmente sbaglio qualcosa da queste parti:
Codice: Seleziona tutto
<br>--tags--<img src="http://img60.imageshack.us/img60/7456/minitechnorati.gif" alt="tags" style="vertical-align:middle; cursor:pointer; float:right; " onclick="div = document.getElementById('tag--postID--'); if (div.style.display=='none') {div.style.display='block';} else {div.style.display='none';}"> <div style="display:none; float:left;" id="tag--postID--">&nbsp;--elenco_tags--</div>
&nbsp;&nbsp;
[--categoria--]&nbsp;&nbsp;
:?
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/

Re: Post senza tag che sballano tutto!

Messaggioda Alexiel » 23 novembre 2011, 1:54

Mi rispondo da sola.
Come una scema, modificando il codice di cui non so nulla, avevo tolto il codice --tags-- che chiudeva il tutto e mi sembrava che andasse bene quindi ho pensato "boh, sarà un doppione".
Il codice esatto è:
Codice: Seleziona tutto
--tags--<img src="http://img60.imageshack.us/img60/7456/minitechnorati.gif" alt="tags" style="vertical-align:middle; cursor:pointer; float:right; " onclick="div = document.getElementById('tag--postID--'); if (div.style.display=='none') {div.style.display='block';} else {div.style.display='none';}"> <div style="display:none; float:left;" id="tag--postID--">&nbsp;--elenco_tags--</div>--tags--

che è esattamente il codice esatto (ho tolto le ultime cose che non servono) per mostrare l'immagine di technorati per i tag. Cliccandoci sopra, si visualizzano i tag. Ricliccandoci, si rinascondono.
Bene, ora mi chiudo anche il threads. Adieu.
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/


Torna a HTML, CSS e Javascript

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron