Pagina 1 di 1

Validare il blog

MessaggioInviato: 1 giugno 2008, 17:32
da arunka
Ciao stavo provando a validare il mio blog con w3c, ma ho scoperto che se lo metto come
Codice: Seleziona tutto
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
ho un pò meno di 300 errore, ma se lo metto (come vorrei) in
Codice: Seleziona tutto
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
mi da quasi 1000 errori di cui la maggior parte non dipendono direttamente dal mio codice (ma da come iobloggo me lo genera) e altri che non ne capisco proprio il senso.

Avete da consigliarmi qualche buona guida per scrivere un buon codice valido?

Se volete far la prova di cosa succede, il mio blog è http://mentesconnessa.iobloggo.com

Grazie e scusate per l'ignoranza, ma voglio imparare..

Re: Validare il blog

MessaggioInviato: 1 giugno 2008, 22:20
da arunka
Dunque, questa volta ho preso il codice della pagina, e da 200 errori sono passata 60 che sono sempre gli stessi, ovvero mi da l'errore sul
Codice: Seleziona tutto
>
di un codice immagine qualunque. i.e.
Codice: Seleziona tutto
<img src="http://md.lilypie.com/QzkQp2.png" alt="Lilypie Expecting a baby Ticker" />
con motivazioni:
required attribute X not specified
The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.
Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.


E comunque sia, facendolo dall'url del blog, per xhtml ho ancora la bellezza di 874 errori.


Il CSS scritto da me è valido, quello nella pagina mi da
5 errori per http://static.iobloggo.com/static/windows_js/themes/default.css
4 errori per http://static.iobloggo.com/static/windows_js/themes/alert.css
e 1 a me che forse è nella tagboard

Idee? suggerimenti? aiuti?
:(

Re: Validare il blog

MessaggioInviato: 2 giugno 2008, 10:14
da arunka
Ho risolto la questioni dell'immagini capendo che in xhtml è necessario l'uso di alt.

Ora ogni mia parte del codice è xhtml e css valido, ma analizzando da url ho ancora 765 errori.
:(

Re: Validare il blog

MessaggioInviato: 3 giugno 2008, 16:59
da anija
Iobloggo crea codice HTML e non XHTML. Stai validando una cosa per quello che non è :)

Re: Validare il blog

MessaggioInviato: 3 giugno 2008, 18:04
da arunka
ok, quindi per essere una qualsiasi cosa valida, devo diventare html? Quale dei tanti?

Re: Validare il blog

MessaggioInviato: 3 giugno 2008, 18:06
da anija
Quello messo in automatico da iobloggo:
Codice: Seleziona tutto
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Re: Validare il blog

MessaggioInviato: 3 giugno 2008, 18:21
da arunka
ok grazie mille.
e invece riguardo agli errori di css che mi da solo sul blog ma non sul mio css?
Risultano anche a voi?

Re: Validare il blog

MessaggioInviato: 3 giugno 2008, 18:28
da anija
Sì, sono nei css di iobloggo. Non sono errori bloccanti, sono proprietà che non sono "standard" per tutti i browser ma solo per alcuni. Creano, ad esempio, quei begli effettini quando clicchi la stelletta del segnapost. Niente di bloccante.

Re: Validare il blog

MessaggioInviato: 3 giugno 2008, 19:14
da arunka
Perfetto, grazie mille!