W3C (html) e generatore automatico

Domande e suggerimenti su W3C, accessiblità e compatibilità browser.

Moderatori: Moderatori iobloggo, Moderatori HTML & Grafica

W3C (html) e generatore automatico

Messaggioda Alcy » 7 febbraio 2007, 21:44

Ho un piccolo problema:
mi sto ingegnando da giorni per usare il generatore automatico di iobloggo perché dovrebbe creare codici puliti. E in effetti quando sono andata a provare con il validatore di html mi ha trovato pochissimi errori (rispetto al solito ho fatto salti di gioia ringraziando anija e il suo generatore).
Il mio problema è che se il css è validato, l'html no!

Il template che sto cercando di validare è quello di questo sito http://griffinicorner.iobloggo.com.

Ho messo in un unico box tutto quanto e ho usato il metodo per fare il menù a scomparsa. Temo sia proprio questo il mio problema. Il fatto è che il validatore mi dice (se ho tradotto bene) che non si può inserire una
Codice: Seleziona tutto
<table> o un <frame> dentro uno <span>.


Come posso fare? La table compare in automatico con il calendario e il frame con il pulsante "cerca nel blog".

Ah! La stessa cosa me la faceva con l'archivio, ora ho messo quello "a lista" e non mi da errori.
Alcy
inesperto
inesperto
 
Messaggi: 16
Iscritto il: 8 gennaio 2007, 9:43

Messaggioda puff » 7 febbraio 2007, 22:40

a me il validatore da il bottone verde: 0 errori 0 warnings!

Sul forum se inserisci dei codici html usa il tasto code, avevi incasinato il forum :wink:
puff
Moderatore
Moderatore
 
Messaggi: 1832
Iscritto il: 27 giugno 2005, 14:30
Località: Toscana

Messaggioda Alcy » 7 febbraio 2007, 22:50

ops! grazie puff per aver corretto.
come mai io non lo vedo corretto e mi da 2 errori? guardiamo due cose diverse e mi sono espressa male? (probabile)
Alcy
inesperto
inesperto
 
Messaggi: 16
Iscritto il: 8 gennaio 2007, 9:43

Messaggioda puff » 7 febbraio 2007, 23:11

ho usato il validatore html che ho nel broswer (ora mi da 7 warnings O.o ), il validatore css è down ora :?
puff
Moderatore
Moderatore
 
Messaggi: 1832
Iscritto il: 27 giugno 2005, 14:30
Località: Toscana

Messaggioda Alcy » 7 febbraio 2007, 23:17

Uff! Non voglio arrendermi! Probabilmente sono errori che ho fatto io.
A me continua a darne due. boh.
<a href="http://alcyone.iobloggo.com" target="_blanck">
<img src="http://alcyonewebber.altervista.org/_altervista_ht/banneralcy.jpg" alt="Alcyone" border="0"></a>
Alcy
inesperto
inesperto
 
Messaggi: 16
Iscritto il: 8 gennaio 2007, 9:43

Messaggioda anija » 8 febbraio 2007, 10:17

Allora :)
Se validi con questo:
http://validator.w3.org/check?uri=http% ... &verbose=1
da' gli errori (quello integrato in Firefox è un po' diverso!)

Il primo errore è dovuto al fatto che hai inserito la ricerca dentro a
Codice: Seleziona tutto
span class="submenu" id="sub5"

Forse per avere un menu dinamico apri/chiudi? Tu cambia SPAN in DIV, lì e anche sotto, nel calendario, e sarà valido.
Lo SPAN dovrebbe contenere sempre solo testo, non tabelle o campi.
Immagine

regolamento // guida // faq // cerca
Immagine
« sei in intimo allineamento con il palpitante ronzio del Divino Wow » Rob Brezsny
Immagine Immagine Immagine Immagine
Avatar utente
anija
Admin
Admin
 
Messaggi: 7745
Iscritto il: 3 marzo 2004, 16:59
Località: Milano
Indirizzo blog: http://anija.iobloggo.com

Messaggioda Alcy » 8 febbraio 2007, 14:06

Esatto era per avere un menù dinamico. Ora provo a cambiare, ma il menù dinamico rimane comunque?
Alcy
inesperto
inesperto
 
Messaggi: 16
Iscritto il: 8 gennaio 2007, 9:43

Messaggioda Alcy » 8 febbraio 2007, 14:18

Fatto! Funziona e ora è validato! Grazie anija, gentilissima!
<a href="http://alcyone.iobloggo.com" target="_blanck">
<img src="http://alcyonewebber.altervista.org/_altervista_ht/banneralcy.jpg" alt="Alcyone" border="0"></a>
Alcy
inesperto
inesperto
 
Messaggi: 16
Iscritto il: 8 gennaio 2007, 9:43

Messaggioda anija » 8 febbraio 2007, 15:07

Figurati ;)
Il menu rimane perché l'importante è che ci sia un "elemento" con id e classi corrette. Che poi l'elemento sia uno span o un div, non fa niente :D
Immagine

regolamento // guida // faq // cerca
Immagine
« sei in intimo allineamento con il palpitante ronzio del Divino Wow » Rob Brezsny
Immagine Immagine Immagine Immagine
Avatar utente
anija
Admin
Admin
 
Messaggi: 7745
Iscritto il: 3 marzo 2004, 16:59
Località: Milano
Indirizzo blog: http://anija.iobloggo.com


Torna a W3C

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite