XHTML e elementi Flash

Domande e suggerimenti su W3C, accessiblità e compatibilità browser.

Moderatori: Moderatori iobloggo, Moderatori HTML & Grafica

XHTML e elementi Flash

Messaggioda Flapper » 6 giugno 2006, 14:42

Ho inserito nella pagina del mio sito un filmato Flash, con un codice del tipo:
Codice: Seleziona tutto
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="..." height="..." align="middle" title="Titolo">
        <param name="movie" value="video.swf" />
        <param name="quality" value="high" />
        <embed src="video.swf" width="..." height="..." align="middle" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed>
</object>


Solo che il validatore non me lo accetta. So che il tag <embed> non sarebbe consentito nel XHTML, però se lo ometto, non mi mostra il filmato :cry:

Ecco quali sono gli errori
Codice: Seleziona tutto
Error  Line 33 column 23: there is no attribute "src".
Error  Line 33 column 41: there is no attribute "width"
Error  Line 33 column 54: there is no attribute "height".
Error  Line 33 column 66: there is no attribute "align".
Error  Line 33 column 83: there is no attribute "quality".
Error  Line 33 column 102: there is no attribute "pluginspage".
Error  Line 33 column 153: there is no attribute "type".
Error  Line 33 column 184: element "embed" undefined.


Come la risolvo?
Immagine
Flapper
purosangue
purosangue
 
Messaggi: 394
Iscritto il: 16 marzo 2004, 18:32
Località: prov di AL

Torna a W3C

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron