Permalink errati

Se hai problemi con la barra di iobloggo o con i template, questo è il posto giusto!

Moderatori: Moderatori iobloggo, Moderatori HTML & Grafica

Permalink errati

Messaggioda ;moch´ » 6 dicembre 2012, 12:01


Salve, il mio problema riguarda i permalink dei commenti, mi spiego meglio: per ogni utente che scrive qualcosa sul mio blog c'è un permalink (oltre il nick, data e ora, e ovviamente il contenuto del commento stesso), ma quando clicco su permalink esce una pagina bianca con scritto 404 - Not Found.
Ho provato a levare dal codice HTML dei commenti questa dicitura
Codice: Seleziona tutto
<a href="--permalink--">PermaLink</a>
ma così facendo mi spariscono anche data e ora.
Quello che vorrei sapere è se c'è un modo per ripristinare questi collegamenti, o altrimenti per togliere la scritta permalink, perchè tanto è inutile visto che si collega ad una pagina bianca.
Vi ringrazio in anticipo per l'aiuto!
;moch´
occasionale
occasionale
 
Messaggi: 28
Iscritto il: 23 novembre 2011, 16:45
Località: Modena
Indirizzo blog: http://moch.iobloggo.com/

Re: Permalink errati

Messaggioda Alexiel » 6 dicembre 2012, 13:19

Probabilmente nel tuo codice c'è qualcosa che proprio non va. :?
Puoi provare a incollarlo qui e a vedere se io o Aru troviamo l'inghippo. Oppure potresti riscriverlo partendo dal codice di base. :D
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/

Re: Permalink errati

Messaggioda ;moch´ » 6 dicembre 2012, 14:42

Ho già cercato di risolvere da sola ma non ci sono riuscita, non capisco proprio cosa c'è che non va!
Vi metto qui il codice dei commenti, sperando che possiate darmi una mano.
In ogni caso grazie!


Codice: Seleziona tutto
<body>
    <style>

    body{
    background-color: #000000;
    margin: 50px;
    cursor: deafult;
    font-family: century gothic;
    font-size: 11px;
    color: #8D8D8D;
    line-height: 10px;}

    .titoli {
text-align: right;
color: #5c6e55;
text-decoration: none;
margin-bottom: 4px;
font-size: 12px;
line-height: 15px;
text-transform: uppercase;
font-family: century gothic;
letter-spacing: -1px;}

.titoli:first-letter
{color: #e0e2e0;
}

.titolopost {
text-align: center;
color: #cac4d3;
margin-bottom: 5px;
font-size: 16px;
line-height: 10px;
text-transform: capitalize;
font-family: century gothic;
letter-spacing: -2px;}




    i, em {
    color: #edb5ee;}

    b, strong {
    color: #b5eedf;}

    u {
    color: #eeb5c0;}

    s{
    color: #b5eeca;}


    a:link, a:visited, a:active {
    font-family: century gothic;
    font-size: 10px;
    text-decoration: none;
    color: #565753;
    cursor: help;}

    a:hover {
    color: #92867e;
    cursor: help;
    letter-spacing: 2px;
    font-weight: bold;
    font-size: 10px;}

    blockquote {
    font-family: arial;
    font-size: 10px;
    text-align: center;
    color: #f1c263;
    margin-right: 3px;
    margin-left: 3px;
    padding: 2px;
    background-color:#a2243c;
    border: 1px solid #8d2034;}
    </style>

     <span class="titoli">Lascia un commento al post:</span> <span class="titolopost">--titolopost--</span><br /><br /><br />
       --commenti_inizio--
        »  --nicknamelink-- <br />
          <a href="--url_website--</a> <a href="--permalink--">PermaLink</a><br />
           --data--<br /><br />
           --commento--<br /><font color=#a2243c><hr></font><br /><br /><br />
       --commenti_fine--
       <br />
       Nome: --inserisci_nickname-- <br /><br />E-mail: --inserisci_email--<br /><br />Website:  --inserisci_website--<br /><br />
        --inserisci_commento--<br /><br />

        --anteprima-- --invia--<br /><br /><br /><a href="javascript:window.close();">chiudi</a><br /><br />--credits--<br />
    </body>
;moch´
occasionale
occasionale
 
Messaggi: 28
Iscritto il: 23 novembre 2011, 16:45
Località: Modena
Indirizzo blog: http://moch.iobloggo.com/

Re: Permalink errati

Messaggioda Alexiel » 6 dicembre 2012, 16:12

Codice: Seleziona tutto
<a href="--url_website--</a> <a href="--permalink--">PermaLink</a><br />

Questa riga è sbagliata.
Vedi il primo a href? Non è completo! Dovrebbe essere una cosa del tipo:
Codice: Seleziona tutto
<a href="--url_website--">URL</a>

Aggiorna questo e dimmi se va tutto a posto ;)
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/

Re: Permalink errati

Messaggioda ;moch´ » 6 dicembre 2012, 16:54

Adesso di fianco alla scritta permalink vedo l'indirizzo completo del mio blog O.O
Comunque dopo aver messo questo
Codice: Seleziona tutto
<a href="--url_website--">URL</a>
non mi si vede più la pagina bianca se clicco sulla scritta, ma il cursore si sposta in basso. .
;moch´
occasionale
occasionale
 
Messaggi: 28
Iscritto il: 23 novembre 2011, 16:45
Località: Modena
Indirizzo blog: http://moch.iobloggo.com/

Re: Permalink errati

Messaggioda Alexiel » 6 dicembre 2012, 17:09

Allora il problema è più grave di quanto pensassi, e riguarda non solo quella parte ma tutto il codice.
Personalmente non me ne intendo moltissimo di HTML e CSS, posso chiedere ad Aru se ha un po' di tempo per aiutarti :)
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/

Re: Permalink errati

Messaggioda arunka » 6 dicembre 2012, 17:54

Il permalink ai commenti non funziona perché in iobloggo non esistono i permalink ai commenti ;)

comunque adesso guardo bene il codice e ti dico come sistemare
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: Permalink errati

Messaggioda Alexiel » 6 dicembre 2012, 18:04

Ehm Aru... esistono :D Ho fatto la prova nel mio codice commenti e funge bene il tag :P
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/

Re: Permalink errati

Messaggioda arunka » 6 dicembre 2012, 18:13

Si è vero. Comunque il template commenti aveva dei codici ripetuti, altri inseriti male ed altri ancora inesistenti.
Ora funziona tutto, devi solo dirmi se ti piace :P

Codice: Seleziona tutto
    <body>
        <style>

        body{
        background-color: #000000;
        margin: 50px;
        cursor: deafult;
        font-family: century gothic;
        font-size: 11px;
        color: #8D8D8D;
        line-height: 10px;}

        .titoli {
    text-align: right;
    color: #5c6e55;
    text-decoration: none;
    margin-bottom: 4px;
    font-size: 12px;
    line-height: 15px;
    text-transform: uppercase;
    font-family: century gothic;
    letter-spacing: -1px;}

    .titoli:first-letter
    {color: #e0e2e0;
    }

    .titolopost {
    text-align: center;
    color: #cac4d3;
    margin-bottom: 5px;
    font-size: 16px;
    line-height: 10px;
    text-transform: capitalize;
    font-family: century gothic;
    letter-spacing: -2px;}




        i, em {
        color: #edb5ee;}

        b, strong {
        color: #b5eedf;}

        u {
        color: #eeb5c0;}

        s{
        color: #b5eeca;}


        a:link, a:visited, a:active {
        font-family: century gothic;
        font-size: 10px;
        text-decoration: none;
        color: #565753;
        cursor: help;}

        a:hover {
        color: #92867e;
        cursor: help;
        letter-spacing: 2px;
        font-weight: bold;
        font-size: 10px;}

        blockquote {
        font-family: arial;
        font-size: 10px;
        text-align: center;
        color: #f1c263;
        margin-right: 3px;
        margin-left: 3px;
        padding: 2px;
        background-color:#a2243c;
        border: 1px solid #8d2034;}
        </style>

     

         <span class="titoli">Lascia un commento al post:</span> <span class="titolopost">--titolopost--</span><br /><br /><br />
           --commenti_inizio--
            »  --nicknamelink-- <br /> --website_url-- <br />
             
              --data--<br /><br />
               --commento--<br /><br /><a href="--permalink--">Permalink</a><br /><br /><br />
           --commenti_fine--
<h2 id="nuovoH2"><span>Nuovo</span></h2>
                    <div class="popupElement" id="nuovo">
                        <div class="popupElementText">
                            <div class="popupElementText2">
                                <b>nome</b><br>--inserisci_nickname--<br><br>
        <b>email</b><br>--inserisci_email--<br><br>
        <b>web</b><br>--inserisci_website--<br><br>
        --inserisci_commento--<br><br>
        --invia--
                            </div>
                        </div>
                    </div>
         

            <br />
<a href="javascript:window.close();">chiudi</a><br /><br />--credits--<br />
        </body>
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: Permalink errati

Messaggioda ;moch´ » 7 dicembre 2012, 12:32

Grazie a entrambi, però anche con l'ultimo codice quando clicco sopra a permalink il mouse si sposta in basso. . Può essere forse perchè manca la dicitura permalink nel codice della pagina?
;moch´
occasionale
occasionale
 
Messaggi: 28
Iscritto il: 23 novembre 2011, 16:45
Località: Modena
Indirizzo blog: http://moch.iobloggo.com/

Re: Permalink errati

Messaggioda arunka » 7 dicembre 2012, 12:47

allora, facciamo un esempio così ci capiamo meglio:
questo è uno dei tuoi commenti preso a caso:
» Nunù
Permalink
01/12/2012 21:43

Certo che lo sarai!!!!!

Bellissimo questo post. Un abbraccio!!!

quando clicchi su permalink la pagina ti si sposta in modo che vedi in alto:
Certo che lo sarai!!!!!

Bellissimo questo post. Un abbraccio!!!

giusto? E' questo che capita?
Perchè se è questo è normale, nel senso che tu cliccando su quel link vieni inviata all'inizio del commento.

Il permalink nella pagina è un'altra cosa (per l'esattezza, è il permalink al post) e non c'entra nulla con i permalink ai commenti.

Il permalink dei commenti è un link che ti invia alll'inizio del commento che vuoi mettere in evidenza. Ma non lo isola dagli altri commenti.
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: Permalink errati

Messaggioda ;moch´ » 7 dicembre 2012, 13:07

Ahhh capisco! Grazie per la spiegazione! Comunque se clicco sul commento di Nunù che è uno dei primi al post mi riporta agli ultimi commenti lasciati. Quindi è tutto a posto? (:
;moch´
occasionale
occasionale
 
Messaggi: 28
Iscritto il: 23 novembre 2011, 16:45
Località: Modena
Indirizzo blog: http://moch.iobloggo.com/

Re: Permalink errati

Messaggioda arunka » 7 dicembre 2012, 13:21

Mah, veramente io se clicco sul permalink del commento di nunù mi rimanda al suo commento esattamente come ti ho spiegato prima.
Se vuoi ti faccio uno screenshoot, ma forse sarebbe meglio che me lo facessi tu...

Comunque ecco qua:
la prima foto è ciò che vedo dopo aver cliccato al permalink al primo commento, mentre la seconda è quello che vedo quando apro i tuoi commenti dell'ultimo post (ho fotografato solo il primo commento per non far vedere a tutti i tuoi commenti)
Allegati
Schermata 2012-12-07 a 12.17.50.png
e questo è quello che vedo dopo aver cliccato su permalink
Schermata 2012-12-07 a 12.19.58.png
questo è quello che vedo quando apro i tuoi commenti dell'ultimo post (ho fotografato solo il primo commento per non far vedere a tutti i tuoi commenti)
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: Permalink errati

Messaggioda ;moch´ » 7 dicembre 2012, 14:46

Ho capito ora cosa intendi per mettere in evidenza!! Però cliccando su permalink di qualsiasi commento della seconda pagina mi porta alla prima, ossia a quelli più recenti.
;moch´
occasionale
occasionale
 
Messaggi: 28
Iscritto il: 23 novembre 2011, 16:45
Località: Modena
Indirizzo blog: http://moch.iobloggo.com/

Re: Permalink errati

Messaggioda arunka » 7 dicembre 2012, 15:07

vero. probabilmente è un bug del permalink. Segnalerò il problema ai tecnici, di più non posso fare.
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Prossimo

Torna a [Problemi tecnici] Template

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron