box commenti non funzionante

Se hai problemi con la barra di iobloggo o con i template, questo è il posto giusto!

Moderatori: Moderatori iobloggo, Moderatori HTML & Grafica

box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 14:08

salve, ho provato a farmi un template da sola e pare che vada bene, l'unica cosa che non sono riuscita a sistemare è il box dei commenti -.- praticamente non mi visualizza i commenti dei miei post, sicuramente non ho inserito correttamente il codice, potreste aiutarmi? ora ho rimesso il vecchio template (funzionante) ma ho salvato il codice su un blocconote
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com

Re: box commenti non funzionante

Messaggioda arunka » 20 febbraio 2012, 15:42

hai due possibilità:
o ci incolli il codice qua (tra due code, tasto che trovi a sinistra),
oppure rimetti il template che non funziona e ci dai l'indirizzo del blog.

Così, senza niente, che possiamo fare?
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 15:53

Codice: Seleziona tutto
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<html>
<head>

<title>commenti</title>
<style type="text/css" title="currentStyle" media="screen">

html{
scrollbar-face-color: #FFCEFF;
scrollbar-shadow-color: #FF6BD6;
scrollbar-highlight-color: #FF6BD6;
scrollbar-3dlight-color: #FFCEFF;
scrollbar-darkshadow-color: #FFCEFF;
scrollbar-track-color: #FFCEFF;
scrollbar-arrow-color: #FFCEFF;
}

body{
text-align: left;
background-color: #000000;
color: #FF6BD6;
font-size: 12px;
font-family: verdana;
}

a:link, a:visited{
text-decoration: underline;
color: #9370DB;
}

a:hover{
color: #8A2BE2;
text-decoration: none;
height: 12px;
}

#popupbody{
background-color: #000000;
}

#contenitore{
text-align: left;
margin-left: auto;
margin-right: auto;
border: 5px ridge #8A2BE2;
width: 410px;
background-color: #000000;
}

#commenti{
text-align: left
color: #000000;
background-color: #FFFFFF;
border: 3px ridge #FF6BD6;
margin-left: 20px;
margin-right: 20px;
margin-top: 10px;
margin-bottom: 20px;
padding: 10px 10px 20px 10px
}

#pageContent h2{
font-family: verdana;
font-size:12px;
background-color:#000000;
margin-left: 20px;
margin-right: 20px;
}

#fondopagina{
margin-left: 20px;
margin-bottom: 20px;
background-color: #000000;
color: #FF6BD6;
}

.pulsanteiobloggo{
margin-left: 110px;
margin-right: 110px;
margin-bottom: 80px;
margin-top: 10px;
}
</style>
</head>

<body id="popupbody">
<div id="contenitore"><!--inizio box commenti-->
<div style="margin-right: 20px; margin-top: 5px; float: right;"><div class="chiudi"><a href="javascript:window.close();">chiudi</a>
</div></div>
<div style="margin-left: 20px; margin-top: 25px"><h3><span><b>COMMENTI:</b></span><h3></div>
 <div id="commenti"><!--inizio_commenti-->
<div class="popupElement">
<div style=" float: right;"><div class="data">--data--</div></div>
#<a href="--permalink--" title="permalink">--numero--</a> --nicknamelink--<br><br>
--commento--<br>
<div style=" float: right;"><div class="gravatar">--gravatar--</div></div>
</div></div>
<!--fine_commenti-->
<h3 id="nuovoH2"><div style="margin-left: 20px;">
<span><b>NUOVO</b></span></h3>
<div id="commenti"><div class="popupElement" id="nuovo">
<div class="popupElementText">
<div class="popupElementText2">
<b>nome</b><br>--inserisci_nickname--<br><br>
<b>email</b><br>--inserisci_email--<br><br>
<b>web</b><br>--inserisci_website--<br><br>
--inserisci_commento--<br><br>
--invia--
</div>
</div>
</div>
</div>
<div id="fondopagina">
--credits--
</div>
</div>
<div id="extraDiv1"><div class="extraDivInner"></div></div><div id="extraDiv2"><div class="extraDivInner"></div></div><div id="extraDiv3"><div class="extraDivInner"></div></div>
<div id="extraDiv4"><div class="extraDivInner"></div></div><div id="extraDiv5"><div class="extraDivInner"></div></div><div id="extraDiv6"><div class="extraDivInner"></div></div>
</body>
</html>


ecco il codice^^
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com

Re: box commenti non funzionante

Messaggioda arunka » 20 febbraio 2012, 16:02

innanzitutto prova togliendo il secondo html (terza riga). lo apri già con la seconda riga e non è necessario riaprilo.
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 16:11

fatto, purtroppo ancora non si vedono i commenti -.-
ho messo il template nuovo al blog fantasyaeris.iobloggo.com
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com

Re: box commenti non funzionante

Messaggioda arunka » 20 febbraio 2012, 16:25

ho trovato l'errore!
devi scommentare
Codice: Seleziona tutto
<!--inizio_commenti-->
(codice nel mezzo)
<!--fine_commenti-->

mettendo
Codice: Seleziona tutto
--inizio_commenti--
...
--fine_commenti--

inizio e fine commenti non sono degli indicatori di codice, ma sono dei veri e propri tag che servono a far funzionare e ripetere il codice che racchiudono.
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 17:06

fatto, ma non funziona uguale :°
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com

Re: box commenti non funzionante

Messaggioda arunka » 20 febbraio 2012, 17:10

il tag --fine_commenti-- non si chiama così XD
si chiamano
Codice: Seleziona tutto
      --commenti_inizio--
..
--commenti_fine--
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 17:13

ok, grazie mille
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com

Re: box commenti non funzionante

Messaggioda arunka » 20 febbraio 2012, 17:15

i nomi dei tag sono errati

questi sono quelli giusti
Codice: Seleziona tutto
--commenti_inizio--
  ..
--commenti_fine--
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 17:34

ora si vedono! solo che il box è un casino -.- devo rimetterci mano sperando di nn creare macelli, cmq grazie mille per l'aiuto!
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com

Re: box commenti non funzionante

Messaggioda arunka » 20 febbraio 2012, 17:54

a me non sembra così male! al massimo devi allargare un po' il div per fare entrare l'editor.
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 18:04

vorrei che ogni commento avesse il suo box biancoconcornicerosa come accade per il primo e per il nuovo e ovviamente cosi non è
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com

Re: box commenti non funzionante

Messaggioda arunka » 20 febbraio 2012, 18:31

te l'ho sistemato, e adesso fa come vuoi tu (scusami se te l'ho anche indentato ma cercare di capire un codice altrui.. è difficile)
Codice: Seleziona tutto
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>

    <title>commenti</title>
    <style type="text/css" title="currentStyle" media="screen">

    html{
    scrollbar-face-color: #FFCEFF;
    scrollbar-shadow-color: #FF6BD6;
    scrollbar-highlight-color: #FF6BD6;
    scrollbar-3dlight-color: #FFCEFF;
    scrollbar-darkshadow-color: #FFCEFF;
    scrollbar-track-color: #FFCEFF;
    scrollbar-arrow-color: #FFCEFF;
    }

    body{
    text-align: left;
    background-color: #000000;
    color: #FF6BD6;
    font-size: 12px;
    font-family: verdana;
    }

    a:link, a:visited{
    text-decoration: underline;
    color: #9370DB;
    }

    a:hover{
    color: #8A2BE2;
    text-decoration: none;
    height: 12px;
    }

    #popupbody{
    background-color: #000000;
    }

    #contenitore{
    text-align: left;
    margin-left: auto;
    margin-right: auto;
    border: 5px ridge #8A2BE2;
    width: 410px;
    background-color: #000000;
    }

    #commenti{
    text-align: left
    color: #000000;
    background-color: #FFFFFF;
    border: 3px ridge #FF6BD6;
    margin-left: 20px;
    margin-right: 20px;
    margin-top: 10px;
    margin-bottom: 20px;
    padding: 10px 10px 20px 10px
    }

    #pageContent h2{
    font-family: verdana;
    font-size:12px;
    background-color:#000000;
    margin-left: 20px;
    margin-right: 20px;
    }

    #fondopagina{
    margin-left: 20px;
    margin-bottom: 20px;
    background-color: #000000;
    color: #FF6BD6;
    }

    .pulsanteiobloggo{
    margin-left: 110px;
    margin-right: 110px;
    margin-bottom: 80px;
    margin-top: 10px;
    }
    </style>
    </head>

    <body id="popupbody">
        <div id="contenitore"><!--inizio box commenti-->
            <div style="margin-right: 20px; margin-top: 5px; float: right;">
                <div class="chiudi"><a href="javascript:window.close();">chiudi</a>
                </div>
            </div>
    <div style="margin-left: 20px; margin-top: 25px"><h3><span><b>COMMENTI:</b></span></h3>
    </div>
    --commenti_inizio--
    <div id="commenti">
        <div class="popupElement">
            <div style=" float: right;">
                <div class="data">--data--
                </div>
            </div>
        #<a href="--permalink--" title="permalink">--numero--</a> --nicknamelink--<br /><br />
    --commento--<br />
            <div style="float: right;">
                <div class="gravatar">--gravatar--
                </div>
            </div>
        </div>
        </div>
    --commenti_fine--
   
   
   
        <div style="margin-left: 20px;">
        <h3 id="nuovoH2"><span><b>NUOVO</b></span></h3>
            <div id="commenti">
                <div class="popupElement" id="nuovo">
                    <div class="popupElementText">
                        <div class="popupElementText2">
                        <b>nome</b><br />--inserisci_nickname--<br /><br />
                        <b>email</b><br />--inserisci_email--<br /><br />
    <b>web</b><br />--inserisci_website--<br /><br />
    --inserisci_commento--<br /><br />
    --invia--
                        </div>
                     </div>
                </div>
            </div>
        </div>
    <div id="fondopagina">
    --credits--
    </div>

    </body>
    </html>

cerca di chiudere i <br /> e rispetta le gerarchie: div - span - stili (h3)
in fondo avevi del codice inutile.
resta da sistemare l'avatar ma io non conosco il funzionamento dei float.
Essere cortesi
Per mia netiquette personale, non fornisco assistenza a chi si rivolge sgarbatamente.
Per ulteriori informazioni leggi qui!

Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!

Presentarsi
Per colpa del molto spam che riceviamo, periodicamente eliminiamo gli utenti registrati senza messaggi. Per evitare che, erroneamente, un account venga cancellato, ti consigliamo di presentarti nella apposita sezione: Presentiamoci!
Avatar utente
arunka
Moderatore
Moderatore
 
Messaggi: 1403
Iscritto il: 7 agosto 2006, 0:15
Indirizzo blog: www.iobloggo.com

Re: box commenti non funzionante

Messaggioda aeriselphie » 20 febbraio 2012, 18:37

cosi va benissimo^^ ora sistemo il float e il colore del font che nel frattempo avevo cambiato e qualche altro aggiustamento che avevo fatto a mio piacere^^
grazie mille ancora, spero di non doverti stressare piu XD
aeriselphie
inesperto
inesperto
 
Messaggi: 12
Iscritto il: 30 gennaio 2012, 15:51
Indirizzo blog: fantasyaeris.iobloggo.com


Torna a [Problemi tecnici] Template

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron