problemi immagine per template con wizard

Se hai problemi con la barra di iobloggo o con i template, questo è il posto giusto!

Moderatori: Moderatori iobloggo, Moderatori HTML & Grafica

problemi immagine per template con wizard

Messaggioda arpista » 1 dicembre 2010, 18:32

Ciao a tutti!
per anni ho utilizzato template fatti da altri: da quando c'è l'opzione wizard ho invece avuto voglia di sperimentarmi nella creazione del mio template. Ho un problema che mi fa scervellare ormai da mesi sull'immagine da mettere come intestazione. Io salvo le immagini su photobucket, poi metto il link e si verificano due fenomeni:
1-se riduco la foto di grandezza, ma lasciandola nella sua forma originaria, questa viene riportata e ripetuta nell'intestazione. (es: http://i229.photobucket.com/albums/ee9/ ... 2468-1.jpg)
2-se invece salvo precedentemente la foto in formati rettangolari come 700X315 la foto che già di per sè mi si sgrana in quel nuovo formato, viene zoommata, diventando pixellosissima! :( (esempio: http://i229.photobucket.com/albums/ee9/ ... e/onda.jpg )

P.s: ho trovato questa discussione viewtopic.php?f=29&t=6305 ed ho provato ad inserire su css personalizzato questo

#pageHeader {
width: 30px;
height: 30px;
background-image: url(www.immagine.it);
background-repeat: no-repeat;
background-position: top;
}
ma non cambia nulla!

Vi ringrazio in anticipo, sono piuttosto esaurita da questa faccenda :D
arpista
inesperto
inesperto
 
Messaggi: 17
Iscritto il: 26 luglio 2004, 19:34
Località: Arezzo

Re: problemi immagine per template con wizard

Messaggioda Alexiel » 1 dicembre 2010, 19:10

Uhm... fammi capire. hai provato a mettere le due immagini linkate.
La prima è troppo piccola quindi ti si ripete (anche col codice che hai postato?), la seconda è troppo grande e ti diventa piccolissima, vero (non è che ti diventa proprio 30x30? dato che nel css hai messo queste dimensioni, e non ho capito perché...)?
Allora... prima di tutto secondo il mio (modestissimo) parere, dovresti andare a vedere quanto è grande lo spazio dove inserire l'immagine. Attualmente hai un'immagine più larga rispetto allo spazio disponibile, infatti te ne taglia una parte. Una volta trovate le dimensioni giuste, crea un'immagine che sia esattamente di quei pixel, e vedi come va.
Fammi sapere.

PS: vado per tentativi. Se poi ti risponde Arunka, credi più a lei :D
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/

Re: problemi immagine per template con wizard

Messaggioda arpista » 1 dicembre 2010, 19:25

Alexiel ha scritto:Uhm... fammi capire. hai provato a mettere le due immagini linkate.
La prima è troppo piccola quindi ti si ripete (anche col codice che hai postato?), la seconda è troppo grande e ti diventa piccolissima, vero (non è che ti diventa proprio 30x30? dato che nel css hai messo queste dimensioni, e non ho capito perché...)?
Allora... prima di tutto secondo il mio (modestissimo) parere, dovresti andare a vedere quanto è grande lo spazio dove inserire l'immagine. Attualmente hai un'immagine più larga rispetto allo spazio disponibile, infatti te ne taglia una parte. Una volta trovate le dimensioni giuste, crea un'immagine che sia esattamente di quei pixel, e vedi come va.
Fammi sapere.

PS: vado per tentativi. Se poi ti risponde Arunka, credi più a lei :D


Ciao Alexiel e innanzi tutto grazie per la rapidità:
La prima fa proprio quello che dici: si ripete anche col codice che ho postato...
La seconda non diventa piccolissima, ma anzi zoomma lìimmagine, si sgrana tanto che non si riesce a leggere tutta la scritta. In realtà non ho messo dimensioni io di 30X30, ho sempre e solo modificato i colori del blog e l'immagine appunto...

Quello che mi dici mi fa sorgere domande banali: come si fa a vedere quanto è grande lo spazio dove inserire l'immagine?
arpista
inesperto
inesperto
 
Messaggi: 17
Iscritto il: 26 luglio 2004, 19:34
Località: Arezzo

Re: problemi immagine per template con wizard

Messaggioda Alexiel » 1 dicembre 2010, 19:45

Fondamentalmente sono cose che si dovrebbero vedere dal template (css o html). Io ad esempio me lo scrivo da me e quindi so sempre quanto deve essere larga l'immagine.
Per quanto riguarda l'altezza invece, probabilmente non conta e non dà problemi. Visualizzando il codice del blog però non riesco a trovare le informazioni che mi servono... Questo proprio perché l'immagine che hai inserito è più grande del dovuto...
Be', io non sono bravissima, comunque... Se consideri che la pubblicità sulla barra è leggermente più piccola dello spazio per il tuo header, e questa ha una larghezza di 728 pixel, puoi regolarti di conseguenza. Che so, prova con un'immagine da 730 pixel e vedi come va! :D

Se è un template genrato col wizard, elimina quella parte del codice che hai scritto, può darsi che crei più danni che altro. Poi magari la si rimette, se serve.
Cercare prima di postare
Prima di postare una richiesta d'aiuto, usate la ricerca! Qualcuno prima di voi potrebbe aver già avuto lo stesso problema!
(cit. regolamento: http://forum.iobloggo.com/viewtopic.php?f=1&t=4)

Immagine Immagine
Avatar utente
Alexiel
Moderatore
Moderatore
 
Messaggi: 1777
Iscritto il: 3 agosto 2004, 16:32
Località: Napoli
Indirizzo blog: http://alexiel.iobloggo.com/


Torna a [Problemi tecnici] Template

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron