Pagina 1 di 1

Problemino commenti

MessaggioInviato: 23 novembre 2007, 19:52
da bimba
E' qualche giorno (forse di più, ma non aggiornavo da parecchio) che non si apre la finestra dei commenti, vorrei capire come mai.

Grazie :ciao: .

Mi scuso se non è la sezione giusta :oops:

MessaggioInviato: 23 novembre 2007, 21:05
da arunka
Qualche altro indizio?

Magari un errore di codice.. purtroppo il tuo blog è privato ed è difficile sbirciare nel tuo template..

MessaggioInviato: 23 novembre 2007, 21:13
da bimba
Se può servire ti faccio accedere così sbirci nel template :)
Oppure se mi dici in quale parte del template può esserci l'errore la copio qui.

Fammi sapere e... Grazie! :*

MessaggioInviato: 23 novembre 2007, 21:35
da arunka
bimba ha scritto:Se può servire ti faccio accedere così sbirci nel template :)
Oppure se mi dici in quale parte del template può esserci l'errore la copio qui.

Fammi sapere e... Grazie! :*


beh, vedi tu.
Per caso ultimamente hai messo mano al template? magari hai semplicemente cancellato il tag --commenti-- oppure hai messo in amministrazione "commenti nella stessa pagina del template" e poi invece hai inserito il codice per li commenti in un altra pagina.

Prova a guardare.

MessaggioInviato: 23 novembre 2007, 21:57
da bimba
Adesso che mi ci fai pensare....
Forse ho lasciato in amministrazione "commenti nella stessa pagina" perché volevo fare in modo che apparissero sia in una nuova finestra che nella stessa pagina, ma non ho capito come modificare il template :cry: .
E, da distratta quale sono, ho lasciato le cose a metà.... Un genio :doh:.
Mi potresti dare una mano?:oops:

Cmq ora hai l'accesso al mio blog :)

MessaggioInviato: 23 novembre 2007, 21:58
da arunka
prima cosa controlla:
amministrazione->blog->commenti->Stile commenti
da quello che vedo io dovresti aver inserito "nella stessa finestra del blog"

ora vai in template ->post
che codice hai per i commenti?
--commenti--
oppure --show_commenti--?

nel caso tu abbia --commenti-- allora il tuo problema è di incopatibilità con quello che hai dichiarato prima. nel senso: se metti "in un altra finestra" allora nel tepmlate metti --commenti--, altrimenti ci vuole l'altro.

altra possibilità tra --show_commenti-- c'è il nulla (ed è per questo che non vedi nulla).

Fammi sapere.
Può darsi che non sia stata chiara, in tal caso mi rispiego

MessaggioInviato: 23 novembre 2007, 22:01
da arunka
dunque: se vuoi che appaiano entrambe le possibilità, credo (ma non ne sono poi così sicura) tu debba inserire entrambi i 2 codici.

innanzi tutto però fai la prova: prova a rimettere "in un altra finestra" e vediamo cosa succede. quasi sicuramente tu non hai inserito il codice per i commenti nella stessa pagina.

MessaggioInviato: 23 novembre 2007, 22:10
da bimba
Come hai detto ho inserito "nella stessa finestra del blog" e nel template --> post c'è --commenti--.

Se volessi i commenti sia nella stessa finestra che in una nuova come dovrei modificare il template? :?

MessaggioInviato: 23 novembre 2007, 22:17
da arunka
non sono sicura funzioni, però oltre a quello che già hai, devi inserire nella pagina POST un codice del tipo:

Codice: Seleziona tutto
--show_commenti--

<html>


<style>

body, td, tr {
color: #000000;
font-family: Arial;
font-size: 9px;
}
      </style>
   <head> 
<style>
     INPUT {
border: #000000 1px solid; 
font-size: 9px; 
font-family: Arial; 
color: #ff3366; 
background-color: trasparent;
}
 a {font-family: Arial; height:0;font-weight: bold; font-size: 9px; text-decoration: none; color: #ff3366;}
          A:link{COLOR: #ff3366; TEXT-DECORATION: none; font-weight: boldl;}
          A:visited{COLOR: #ff3366; TEXT-DECORATION: none; font-weight: boldl;}
          A:active{COLOR: #ff3366; TEXT-DECORATION: none; font-weight: boldl;}
          a:hover {text-decoration: none; color: #990066; cursor: nw-resize;}
</style>
     </head>
   
<body>
<table width="50%" border="0" align="center">
  <tr>
    <td width="40%"><div align="center"><strong>Nome:</strong></div></td>
    <td width="40%"><div align="center">--inserisci_nickname--</div></td>
  </tr>
  <tr>
    <td><div align="center"><strong>E-Mail:</strong></div></td>
    <td><div align="center">--inserisci_email--</div></td>
  </tr>
  <tr>
    <td><div align="center"><strong>Website:</strong></div></td>
    <td><div align="center">--inserisci_website--</div></td>
  </tr>
  <tr>
    <td colspan="2"><div align="center">--inserisci_commento--</div></td>
  </tr>
  <tr>
    <td><div align="center"><strong>--anteprima--</strong></div></td>
    <td><div align="center"><strong>--invia--</strong></div></td>
  </tr>
</table>
<p>--commenti_inizio--</p>
<table width="50%" border="1" bordercolor="#000000">
  <tr bordercolor="#FFFFFF">
    <td><strong> --numero-- | --nicknamelink--</strong></td>
  </tr>
  <tr bordercolor="#FFFFFF">
    <td><strong>--data--</strong></td>
  </tr>
    <tr bordercolor="#000000" bgcolor="#990066">
    <td><font color="#FFFFFF"><strong>--commento--</strong></font><div>--gravatar--</div></td>
  </tr>
</table>
<p>--commenti_fine--</p>
 
</body>
</html>
--show_commenti--


non sono sicra funzioni. e se l'ho copiato male, te lo mando per posta come allegato.

MessaggioInviato: 23 novembre 2007, 22:19
da arunka
ovviamente devi anche mettere --commenti-- (con relativo codice in TEMPLATE->COMMENTI)

quello che ti ho messo sopra è il codice che usavo anni fa per il mio blog, scopiazzato da quelli di default di iobloggo. in realtà io ho sempre usato i commenti pop-up quindi non sono sicura funzioni.

MessaggioInviato: 23 novembre 2007, 22:46
da bimba
Funziona, ho fatto una prova.
Appena posso ci "pasticcio" un po' e lo sistemo.

Grazie mille per l'aiuto :*

MessaggioInviato: 23 novembre 2007, 23:50
da arunka
Di niente, un bacio!