Codice per cookies inseriti dal blogger: problemi

Per qualsiasi problema tecnico riguardante iobloggo!

Moderatore: Moderatori iobloggo

Codice per cookies inseriti dal blogger: problemi

Messaggioda Antikosmikos » 14 luglio 2015, 10:32

Buongiorno,
Mi dispiace di tediare con le mie richieste, ma ho un problema con i cookies, e penso proprio di non essere l'unico. Si tratta dei cookies aggiunti dal blogger, di cui si parla nella sezione privacy policy di Iobloggo:

"IoBloggo fornisce ad ogni blogger la possibilità di adempiere alla normativa in vigore inserendo un codice personalizzato che inibisca l'utilizzo dei cookie sino a che non siano stati approvati dagli utenti.
Tutti i codici di terze parti dovranno essere convertiti in codice Javascript e inseriti all'interno del seguente codice:
if (document.cookie.indexOf('cookieconsent_dismissed') > -1) {
//codice terze parti
}

Il codice fornito non mi funziona, senza dubbio per mia incapacità (non sono un programmatore). Sono partito dal codice di un filmato di Youtube:

<iframe width="320" height="230" frameborder="0" src="https://www.youtube.com/embed/9Gzew4u44kQ?feature=player_detailpage" allowfullscreen=""></iframe>

L'ho tradotto in Javascript tramite il seguente convertitore:
http://www.latrinakria.it/servizi/webmaster/convert_html-java.htm

Questo è il codice Javascript che ho ottenuto:

<script language="JavaScript">
info="<iframe width=&#34;320&#34; height=&#34;230&#34; frameborder=&#34;0&#34; src=&#34;https://www.youtube.com/embed/9Gzew4u44kQ?feature=player_detailpage&#34; allowfullscreen=&#34;&#34;></iframe>"
document.write(info)
</script>

Ho quindi inserito nell'html del post (ancora in fase di bozza) il seguente codice:

<script language="JavaScript">
if (document.cookie.indexOf('cookieconsent_dismissed') > -1) { //info="<iframe width=&#34;320&#34; height=&#34;230&#34; frameborder=&#34;0&#34; src=&#34;https://www.youtube.com/embed/9Gzew4u44kQ?feature=player_detailpage&#34; allowfullscreen=&#34;&#34;></iframe>"
document.write(info)}</script>

Non funziona neanche con <script type="text/JavaScript">, e neppure con il semplice <script>. E' indifferente che aggiunga o meno <html>, <head> o <body>. Niente. Il video diventa invisibile, sparisce. Come se non esistesse più.

Cosa sto sbagliando?
Si nota che se si inserisce if (document.cookie.indexOf('cookieconsent_dismissed') > -1) { // senza usare <script> o simili, il codice (che non è html) non funziona e appare come un qualsiasi testo nella pubblicazione, proprio sopra il video.

Ho letto questo:
"A breve pubblicheremo una guida per aggiornare il proprio blog nelle principali casistiche.
IoBloggo declina ogni responsabilità in caso in cui un blogger non adegui il proprio blog in base alla nuova normativa."

Faccio presente che la legge sui cookies è già perfettamente operativa, che la questione è della massima urgenza e importanza per tutti gli utenti della piattaforma e non può essere passata sotto silenzio: pochissimi hanno le competenze tecniche per usare correttamente il codice fornito, che è stato sbattuto lì senza spiegazione alcuna, sostanzialmente senza badare alle possibili conseguenze per i blogger - che a quanto pare vivono beatamente senza sapere che in pratica nessun portale è a norma.
Si tenga conto che l'uso di questo codice, anche quando funzionerà correttamente, è molto oneroso: in pratica bisogna individuare ogni singolo filmato, ogni singola immagine e modificare i relativi post. Un lavoro estenuante.

Sperando in un riscontro, anche da parte di membri della comunità, ringrazio in anticipo e pongo i miei cordiali saluti.
Marco
Antikosmikos
occasionale
occasionale
 
Messaggi: 39
Iscritto il: 1 aprile 2012, 15:58
Località: Milano
Indirizzo blog: http://catarismo.iobloggo.com

Torna a Problemi tecnici

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite